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Molecular orbitals and energy curves for diatomic molecules

A. Molecular orbitals of N2

Do Hartree-Fock calculations of an N2 molecule using the 6-31G basis set. To create the molecule, open
(Edit→Add atom), select nitrogen in the interactive periodic table and left-click on the main Chemcraft
window. To create an N2 molecule, left-click on the center of the N atom. Center the molecule (press Space)
and use ‘Best View’ (press Enter).

Click on ‘Source’ tab and copy the atomic coordinates to the clipboard. Create a new ORCA input
file. We will use the Hartree-Fock method as the electronic structure method, 6-31G as the basis set and
perform an equilibrium structure search (keyword: opt). The aforementioned options should be placed in
the ‘simple-input’ line of the input file. Also, add the keyword ‘normalprint’ to the simple input line. Below
that create the geometry block and copy-paste the coordinates into the geometry block (see lab 2).

We want ORCA to print information about the molecular orbitals to the output file so that Chemcraft
can visualize them. Place the following ‘output’ block in between the ‘simple-input’ line and the ‘geometry
block’ (same as for the H2 molecule in lab 2).

%output
Print[ P_Basis ] 2
Print[ P_MOs ] 1
end

Copy a jobscript to your working directory and run the calculation (>> squeue sub.sh). When the
calculation has finished, copy the output file back to your local machine and visualize the molecular or-
bitals in the same way as you did for H2 in lab 2. Open the output file (‘orca.out’) with ChemCraft, go to
Tools→Orbitals→Render molecular orbitals. You will see a list of molecular orbitals, including the
energy and occupancy of each one. The molecular orbitals are doubly occupied in this case. This is because,
N2 is a closed-shell system and we are using (by default) the restricted Hartree-Fock method, where the
same spatial orbital is used for both spin-up and spin-down electrons. If you click on ‘Check orbitals’ you
can find more information about the molecular orbitals, e.g., orbital type and expansion coefficients for the
various basis functions. Now visualize and save an image of both the HOMO and LUMO.

Then, repeat the calculation using unrestricted Hartree-Fock method. Copy the jobscript and ORCA
input file into a new directory. Change the keyword ‘HF’ to ‘UHF’ in the ‘simple-input line’ of the input
file and submit the job. When the calculation has finished, open the output file with ChemCraft and select
Tools→Orbitals→Render molecular orbitals. Now you will find both Alpha Orbitals and Beta Or-
bitals. They correspond to molecular orbitals with spin up and spin down electrons, respectively.

Select the spin-up LUMO+1, i.e., the second orbital with an occupation of 0.0 in the Alpha Orbitals
tab. Note that it can be a good idea to slightly increase the ‘Map points per angstrom’ to increase resolution
of the rendered surfaces. Click OK. Click on ‘Show isosurface’ and ‘Both-signed’. Select a suitable isocontour
value.

Now rotate the molecule, so that the bond is in the plane of the screen and you can see all four lobes of
the orbital. In order to be able to visualize the LUMO and the π-orbitals with the same perspective, it is
good to rotate the molecule so that you view the plane of the lobes under an angle (not along its normal).
Adjust the zoom and/or the window size so that the whole orbital is displayed on the screen.
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Save an image of the orbital by File→Save As→Save image. Give the file some descriptive name, for
example LUMO+1.jpg. Repeat this for LUMO and the occupied spin-up orbitals (LUMO, HOMO, HOMO-
1, ...).

Record the energy of the orbitals you have displayed, up to and including the LUMO+1. You find the
values in the ‘Orbitals’ window, but it might be easier to copy and paste them from the log file. The values
are close to the end of the output file under the title ’ORBITAL ENERGIES’. The occupation number
(OCC) is zero for unoccupied orbitals (referred to as virtual orbitals). Since an unrestricted wave function
was calculated, no two electrons share the same spatial orbital, and the occupied orbitals therefore have an
occupation number of 1.0.

Q1: Display all the MOs of the N2 molecule in your report and classify each one of them as bonding,
antibonding or non-bonding, and say whether the symmetry of the orbital is σ or π. Sketch a molecular
orbital diagram using the values of the energy of the MOs from the output file and compare your diagram
with the one in your physical chemistry or first year chemistry textbook.

B. Molecular orbitals of O2

Repeat part A of this lab for the O2 molecule. But, first calculate the minimum energy for the singlet
state and then calculate the minimum energy for the triplet state. You can specify the spin multiplicity
in the ORCA input file. Should you use unrestricted or restricted Hartree-Fock for a calculation of the O2
molecule?

Q2: Which spin state is lower in energy for the O2 molecule? Explain by referring to the energy of the MOs
(recall Hund’s rule). Note, that when you do calculations of the triplet state, there is a listing of both alpha
and beta MOs.

Save pictures of the orbitals up to LUMO+1 and record the energy of the orbitals. If you found the
triplet state to be lower, do this for both the spin-up and spin-down orbitals.

Q3: Display the MOs for the ground state of the O2 molecule in your report and classify each one as bonding,
antibonding or non-bonding, and say whether the symmetry of the orbital is σ or π. Sketch a molecular orbital
diagram using the values of the energy of the MOs from the output file. If you found the triplet state to be
lower in energy, include both the spin-up and spin-down orbital energy in the diagram.

C. H2 energy profile #1

Q4: Write the Slater determinant wavefunction for (a) He and (b) Li atom, expand the determinant and
simplify.

In this part of the exercise you will calculate the energy of the H2 molecule as a function of the distance
between the atoms. This illustrates nicely the Born-Oppenheimer approximation and how an energy curve
(more generally an energy surface) is generated in the first step of the two-step Born-Oppenheimer procedure.
In the second step, the motion of the nuclei is calculated and this will be the topic of a later lab session.

Instead of Cartesian coordinates, it is more convenient here to use so-called ‘Z-matrix’, or, ‘internal
coordinates’. There, the position of atoms is specified relative to each other, in terms of distances, bond
angles and dihedral angles (the dihedral A-B-C-D corresponds to the angle formed by the vectors B-A and
C-D). The first atom listed in the Z-matrix is the reference point. The position of the next atom is described
by the distance from the first. The location of the third atom is described by the distance from one of the
atoms and the angle formed by the bond to the other atom. All further atoms are fixed by a distance, a
bond angle, and a dihedral angle relative to other atoms.
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With internal coordinates (instead of Cartesian coordinates) the geometry block of the ORCA input file
has the general form

* int 0 1
AT0 0 0 0 0.0 0.0 0.0
AT1 RB1 0 0 B1 0.0 0.0
AT2 RB2 RA2 0 B2 A2 0.0
AT3 RB3 RA3 RD3 B3 A3 D3
AT4 RB4 RA4 RD4 B4 A4 D4
\dots
*

For a methane molecule, for example:

* int 0 1
C 0 0 0 0.000 0.000 0.000
H 1 0 0 1.089 0.000 0.000
H 1 2 0 1.089 109.471 0.000
H 1 2 3 1.089 109.471 120.000
H 1 2 3 1.089 109.471 -120.000
*

Here, int indicates internal coordinates (while xyz indicates Cartesian coordinates). The section contains
one line per atom, but now you specify the index (number) of the reference atoms for bond-length (RB),
angle (RA) and dihedral (RD) followed by the respective values for the distance, bond angle and dihedral
angle. The carbon atom is the reference point, so no values have to be specified there, i.e., all values are
zero. The second atom, a hydrogen atom, is specified by a distance of 1.089 Å from the carbon atom, atom
1 in the list. The reference indices for angle and dihedral are, as well as their values, zero. The third atom
is defined. The second hydrogen atom has the same C-H distance, and a H-C-H angle of 109.471◦. The last
two hydrogen atoms have the same C-H distance and H-C-H angle, but the dihedral has to be specified with
respect to the third hydrogen atom.

For larger and more complicated molecules it is convenient to use ChemCraft to generate a Z-matrix from
the Cartesian coordinates. This can be done using the (Tools→Build Z-Matrix) and choosing a format.
However, the only degree of freedom (excluding global rotation and translation) in the H2 molecule is the
bond length between the two atoms, so it is very easy to manually construct a Z-matrix for the H2 molecule.
Simply copy-paste the following Z-matrix:

H 0 0 0 0.000000000000 0.00000000 0.00000000
H 1 0 0 0.750000000000 0.00000000 0.00000000

to the geometry block of your ORCA input file (remember to replace ’*xyz’ by ’*int’ to inform ORCA that
you are indeed using internal coordinates).

Now, create an ORCA input file. Perform an equilibrium structure search using HF/6-31G (method/basis
set). The input file should also contain the Z-matrix description of the hydrogen molecule, described merely
by the bond length. Run the calculation. After finding the distance that gives lowest energy (the equilibrium
structure) has been found, the final geometry can be read the from the output file. Search for the last
occurrence of INTERNAL COORDINATES (ANGSTROEM). Below, the final Z-matrix is displayed.
Record the value of the bond length. Also record the energy of the molecule, which is given after the text
FINAL SINGLE POINT ENERGY close to the end of the output file.

Now calculate a part of the energy curve for the H2 molecule (i.e. the energy of the molecule vs. dist-
ance between the atoms by doing a sequence of single point calculations. Let the distance vary between
r0−0.2 ≤ rHH ≤ r0+0.2 Å, where r0 is the optimal bond length (obtained from the geometry optimization).
To do this, perform four single point calculations with varying values of rHH, where the bond is stretched
(r0+0.2, r0+0.1) and compressed ( r0−0.1, r0−0.2). It is good practice to keep all calculations/data and th-
erefore create a sub-directory for each single point calculation. Copy the ORCA input file and jobscript from
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the geometry optimization to all sub-directories. Then, open fresh copies of the input files and remove the
opt keyword (this will instruct ORCA to do only a single point energy calculation). Also, change the bond
lengths in the Z-matrix to the aforementioned values. When the calculations finish, record the correspond-
ing energy of the H2 molecule.This procedure illustrates the Born-Oppenheimer approximation and shows
how potential energy surfaces for the motion of atoms can be generated from electronic structure calculations.

Q5: Make a graph of the energy of the H2 molecule versus the distance between the atoms (using for example
Matlab or Gnuplot). Select the zero of energy to be the energy of two isolated H atoms.

D. H2 energy profile #2
The process described above is a bit tedious and is not efficient for calculating many points on the energy
curve. While it is still possible for diatomic molecules, more complex systems have far too many degrees of
freedom to do this procedure by hand. Fortunately ORCA has an option for doing this automatically. To
instruct ORCA to do a sequence of calculations varying the H-H bond length, the following lines are inserted
directly before the geometry specification:

%geom Scan
B 0 1 = 0.40, 2.00, 17
end
end

This defines a scan of the bond length (B) between the first and second atom (the atoms are counted
starting from 0). The initial bond length will be 0.40, the final distance will be 2.00 and there will be 17
equidistant points in this interval.

Create a new directory for this calculation. Copy a jobscript to the directory and create an ORCA input
file (see below). Run the calculation.

!HF 6-31G OPT

%geom Scan
B 0 1 = 0.40, 2.00, 17
end
end

*int 0 1
H 0 0 0 0.000000000000 0.00000000 0.00000000
H 1 0 0 0.750000000000 0.00000000 0.00000000

At the end of the output file, below The Calculated Surface using the SCF energy, you will find
a table containing the energy of the molecule at the various values of the bond length. Copy this data into
your report.

Q6: What value should the energy approach when the bond length is increased to infinity? Does the binding
curve you calculated indicate this?

By default, ORCA carries out a restricted Hartree-Fock calculation when the spin multiplicity is 1. This
means that the spin-up (alpha) and spin-down (beta) orbitals have the same spatial distribution, i.e. they
have the same coefficients in the expansion in terms of the basis functions.

Every calculation starts from an initial guess for the orbitals. The ‘better’ the guess, the sooner the
calculation converges. But, if the initial guess has some symmetry, it is usually retained throughout the
minimization. The initial guess for the hydrogen molecule wave function corresponds to a restricted Slater
determinant, also when an unrestricted HF calculation is specified. To break this ‘spin-symmetry’, we can
use ’broken symmetry’. To do this, add the following lines directly after the ’simple-input’ line of the input
file.
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%scf Brokensym 1,1 end

This instructs ORCA to mix the singlet and triplet wave-functions in order to break the spatial and spin
symmetry. Run the UHF calculation from this input and record the energy as a function of bond length.

Now carry out a calculation of the energy curve for the triplet state of H2. The spin multiplicity should
in this case be set to 3. Run the calculation and record the energy as a function of bond length.

Q7: Create one graph with three curves: (1) the singlet state calculated using restricted Hartree-Fock (RHF),
(2) the singlet state calculated using unrestricted Hartree-Fock (UHF), and (3) the triplet state. Also, add a
horizontal line at the energy of two isolated hydrogen atoms.

Q8: Compare the RHF and the UHF curves for the singlet state. Describe the problem that occurs in the
RHF calculation for large bond length. What is the reason for it? Hint: Write the Slater determinant for H2

using bonding molecular orbitals (in terms of 1s atomic orbitals), then expand and simplify to identify the
terms responsible for the large increase in energy as the distance between the atoms increases.

Q9: Can two H-atoms form a bond in the triplet state? Explain.

Finally, run the unrestricted HF calculation for the singlet state without the mixing of the initial orbitals.
To do so, remove the % scf block.

Q10: How does the binding curve of this calculation differ from the previous UHF calculation? Explain.
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